Flex Builder and Eclipse 3.5

Here’s a blog post by a frustrated developer who seems to have found out how to set up the Flex Builder plugin with Eclipse 3.5 (I have tried it and it works!).  Thank you, frustrated developer!

http://worldwizards.blogspot.com/2009/08/eclipse-35-and-flex-builder.html

From the post:

(1) Download and install Eclipse 3.5. I used the J2EE install.
(2) Download and run the Flex Builder 3 installer.
(3) Ignore all the warnings that it only supports Eclipse 3.3 and 3.4. Just keep telling it that you know what you are doing and want to install it anyway. It will end with a scary message about failing and suggest you do a manual install from inside of eclipse. Don’t do that!
(4) Here is the magic, when it is done there will be a file in your eclipse/links directory called
com.adobe.flexbuilder.feature.core.link
Open that file in wordpad and you will see it contains one line:

C:/Program Files/Adobe/Flex Builder 3 Plug-in

Edit that line so it looks like this:

path=C:/Program Files/Adobe/Flex Builder 3 Plug-in

Save the file and start eclipse. Voilla!

VN:F [1.9.22_1171]
Rating: 5.0/5 (9 votes cast)
VN:F [1.9.22_1171]
Rating: +4 (from 4 votes)
Flex Builder and Eclipse 3.5, 5.0 out of 5 based on 9 ratings

16 thoughts on “Flex Builder and Eclipse 3.5”

  1. Thanks a bunch, works perfectly!

    VA:F [1.9.22_1171]
    Rating: 5.0/5 (2 votes cast)
    VA:F [1.9.22_1171]
    Rating: +2 (from 2 votes)
  2. It works great for me, too. Thanks a bunch.

    VA:F [1.9.22_1171]
    Rating: 5.0/5 (1 vote cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  3. “path=C:/Program Files/Adobe/Flex Builder 3 Plug-in” – wow, been searching for this for hours! thank you so much.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  4. You are great. This is eexactly what is needed. Path is missing from that file.

    How did you find it.

    It is really frustating.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: +1 (from 1 vote)
  5. Thanks !!! 🙂 That’s what I needed…

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  6. For me there is a problem. I am in Windows 7 64 bits, my path should be “path=C:/Program Files (x86)/Adobe/Flex Builder 3 Plug-in” but after save and run Eclipse I can’t load the Flex workspace… don’t appear. Any suggestion?

    – –

    Ok, for any reason if my Eclipse directory is in C/Program Files don’t work. I move to desktop and now everything is fine. Thank you admin 🙂

    – –

    I forgot something, eclipse for 64 bits show me an error, but eclipse for 32 is the good way… maybe if I move the eclipse for 32 to C/Program Files I guess that I can load de flex perspective.

    VA:F [1.9.22_1171]
    Rating: 4.0/5 (1 vote cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  7. Thanks, it was very helpful for..saved my hours and hours

    VA:F [1.9.22_1171]
    Rating: 4.0/5 (1 vote cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  8. you basically saved me a half-day of hunting around for a fix 🙂
    thanks for posting!

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  9. Thanks Bro!

    Just like to know anything do u have with SVN plug in on the Oracle Enterprise Pack for Eclipse 11gR1 that will be gr8!

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: +1 (from 1 vote)
  10. Thanks works fine! But isn’t it just poor that the Installer is not able to set the path correctly?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  11. Thanks a lot, that’s very helpful.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  12. Wow, that totally did the trick and ended my hours of frustration.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  13. i downloaded eclipse 3.5 zipped file in that i didn’t find any link file …plz tell me what to do

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  14. The only thing I can say, I love you Dude….

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  15. Thanks for that.. It saved my time really….

    VA:F [1.9.22_1171]
    Rating: 4.0/5 (1 vote cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

Leave a Reply